Menu

Topic-icon mgs1600gy UNABLE TO SETUP ROBOCAN

More
1 year 3 months ago #29534041 by pamon
I need to connect 4 mgs1600gy magnetic sensors with 2 fdc3260 controllers via robocan,
Robocan setup worked fine on FDC3260.
But on magnetic sensor, if a choose robocan into setup and save it to sensor, it turn back to RawCan.
firmware quiery give this:
?fid
FID=Roboteq v1.0 MGS1600 04/24/2014

Does a firmware update can fix this?

i tryed to find an update into the download center, but i am not shure to get the good one. Over that, i fount that i would need a update utility, but doesn'T found this utility anywhere.
Any help is welcome. thank'S

Please Log in or Create an account to join the conversation.

  • Gabriel_Isko
  • Gabriel_Isko's Avatar
1 year 3 months ago #29534044 by Gabriel_Isko
Replied by Gabriel_Isko on topic mgs1600gy UNABLE TO SETUP ROBOCAN
Have you tried the 3.0beta firmware on our downloads page?

You should be able to launch the firmware updated from the MagSensor utility.

Please Log in or Create an account to join the conversation.

More
1 year 3 months ago #29534053 by pamon
i upgraded to 3.0 beta. i am now able to setup robocan .
i can check node with ?icl 2 (this node) it work. Two other nodes are 1 and 4 (both are fdc3260 controllers) node 4 answer 1 at ?icl 1 and ?icl 4, and 0 at ?icl 2
node 1 answer 1 at ?icl 1 and 0 at ?icl 4 or 2
node 2 answer 1 at ?icl 2 both 0 at ?icl 1 or 4
Ultimatly ia would need to connect 4x mgs1600gy and 2x fdc3260 together in robocan.
Does mgs1600gy support usb and robocan simultaneously?

Please Log in or Create an account to join the conversation.

  • Gabriel_Isko
  • Gabriel_Isko's Avatar
1 year 3 months ago #29534058 by Gabriel_Isko
Replied by Gabriel_Isko on topic mgs1600gy UNABLE TO SETUP ROBOCAN
It should have no problem doing that. If you want to double check, send the command ?UID to the controller and let me know what the result is.

Please Log in or Create an account to join the conversation.

More
1 year 3 months ago #29534060 by pamon
I got this:

?uid
UID=100:1044:98434864:842618194:1360156723

Please Log in or Create an account to join the conversation.

  • Gabriel_Isko
  • Gabriel_Isko's Avatar
1 year 3 months ago #29534061 by Gabriel_Isko
Replied by Gabriel_Isko on topic mgs1600gy UNABLE TO SETUP ROBOCAN
Hmm, Your MGS might be two early of a hardware revision. What hardware revisions is it? It should have a revision number on the barcode label on the back of the sensor.

Please Log in or Create an account to join the conversation.

More
1 year 3 months ago - 1 year 3 months ago #29534063 by pamon
Not easy to read, but seam to be 3.1 a 0818 s/n:f38784.
i just received brand new ones. rev 3.1a 1818 s/n:f48966
Will try with it.

the new have firmware 1.0. does not accept robocan configuration instead it is in the can config options...
where can i get firmnware between v1 and v3 beta? History of firmwares show many versions but onlu 1 and 3 beta seem available for download.

I don't want to install a beta version and get into others problems...

Please Log in or Create an account to join the conversation.

  • Gabriel_Isko
  • Gabriel_Isko's Avatar
1 year 1 month ago #29534242 by Gabriel_Isko
Replied by Gabriel_Isko on topic mgs1600gy UNABLE TO SETUP ROBOCAN
Just an update, I believe we have created a relase version of 3.0. This should fix any problems regarding RoboCAN.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.116 seconds
Go to top