Menu

Topic-icon RIOX is blocked and doesn't work

More
1 year 11 months ago - 1 year 11 months ago #29532004 by URBANCLOUDS

Hi,

I have a Riox-1216AHRS for 3 months and I used it without any problems. Today, I changed a parameter and have updated software micro-script. The parameter "print output port" has been set to USB, through the PC utility. When I turn on the Riox again, this has been blocked. All LEDs are turned on, the USB port fails and no communication with the computer.

Just when I turn on the RIOX, LED 1 blinks and the LED13 and LED33 are turned off, all other LEDs are on. After one second, LED1, LED13 and LED33 are activated and remain on.

I tried to connect the RIOX to RS232 interface, when I turn on the device, this returns the message: Starting ...
FID = R
. I tried to communicate with device by RS232 but I have not succeeded either.

Finally, I tried to update the firmware via RS232 COM. The device is detected but fails programming. A capture of the error is attached.

How could I fix this? I need a solution as soon as possible. Thank you

Also, I attach the profile file and the script program that is programmed into the device.

Profile
Script.mbs


Attachments:

Please Log in or Create an account to join the conversation.

More
1 year 11 months ago #29532007 by blake

Hello, I noticed from your attached config file that you have the auto script start enabled. This isn't a bad thing, however Microbasic scripts can cause this to occur if device is loaded with a script that is faulty and start up is set to run script on "Auto Start". To recover, do the following steps, for best results, connect the RS232 instead of USB:

>First, ensure that you have the latest version of the RIOX Configuration Utility. It is available from the downloads page of our website. It is Rev 2.0 with the date 4/22/2016. After updating your utility proceed with the following.

> Power down device if device is on.

> Go directly to the "Scripting" tab of the configuration utility.

> Type in the following code in the first line.

Terminate

> Then place mouse over button that says "Download to device".

> Power on controller.

> As soon as the stop sign on the upper right corner of Roborun+ turns red, click on "download to device" to send the code to terminate and clear out the faulty script.

> If successful, the script will stop trying to run and communication will be stable again.

After completing this process reset your controller to default and/or edit your script as needed.

Please Log in or Create an account to join the conversation.

More
1 year 11 months ago - 1 year 11 months ago #29532010 by URBANCLOUDS

Hello,
I tried the procedure you described me and I have not been successful.

First, I have not found the latest version of the Riox Configuration Utility. On the download page that lastest version is: 1.0 with the date 10/10/2015.

After turn on the device, you say I use Roborun+, this application is for motor controller... Is it also valid for Riox?

With Roborun +, the stop sign never turns red, when I give "download to device" the following error occurs:
https://drive.google.com/file/d/0Bxkkt2aViKMvVWhQeHVaUm5GMWc/view?usp=sharing


I have also tried to send the script from the Riox application, but I have same result.


When I turn on the device, this is the the message that is shown in Riox Configuration Utility:
https://drive.google.com/file/d/0Bxkkt2aViKMvcmZZckNGTjBiZjA/view?usp=sharing

Please Log in or Create an account to join the conversation.

More
1 year 11 months ago #29532014 by blake

I apologize, please contact us at This email address is being protected from spambots. You need JavaScript enabled to view it. and I can email you the Utility update file.

I did not mean to type Roborun+, that was a typo on my part. The previously described procedure was to take place entirely in the Riox Utility.

Your device is not completing startup. Another way to clear the script possibly causing the issue is to re upload the firmware. This can be done from the Setup tab of the utility. You will need to manually select your com port instead of using the "Automatically detect the Controller".

Please Log in or Create an account to join the conversation.

More
1 year 11 months ago - 1 year 11 months ago #29532017 by URBANCLOUDS

Hello,

I managed to update the device firmware. During the process I had to reboot the device for the update was successful. This is the result:

Capture

However, RIOX still doesn't respond and is blocked when turn on.

RIOX

Please Log in or Create an account to join the conversation.

More
1 year 11 months ago #29532018 by blake

Please email your config file and script to me at This email address is being protected from spambots. You need JavaScript enabled to view it.. In addition, I'm not sure what time zone you are in but at this point it would be easier to troubleshoot your problem via a phone or skype call. Contact me at that email address and perhaps we can get something set up.

Please Log in or Create an account to join the conversation.

Moderators: opalAmcolex
Time to create page: 0.214 seconds
Go to top