Menu

Topic-icon Set analog output!

More
4 years 9 months ago #29529681 by QuiXXotic

I wonder if anyone managed to set the analog output?
According to PC config utility the analog outputpins is set to work as analog but giving them different values through a python script gives no result.

Please Log in or Create an account to join the conversation.

More
4 years 8 months ago #29529687 by TechSupport

Sorry for the late response.

Try activating the analog via the console (ie serial, USB or minicom) by using the !AO cc nn command. Where cc is 1 or 2 and nn the value from 0 to 4095.

The following user(s) said Thank You: QuiXXotic

Please Log in or Create an account to join the conversation.

More
4 years 8 months ago - 4 years 8 months ago #29529688 by QuiXXotic

Yeah ive tried that and its working...

But a simple python script like

import rioboard

rioboard.Init()
rioboard.WriteAnaOutput(0, 0)
rioboard.WriteAnaOutput(1, 2700)

has no effect. No errors either but no effect on the output. Executing other scripts using digital i/o´s works flawless. If i give them a value in console i cant get the to zero by script either.

Please Log in or Create an account to join the conversation.

  • roboteq
  • roboteq's Avatar
4 years 8 months ago #29529689 by roboteq

We'll have to look into the code. Pls stand by.

If you are in a big hurry, you can always use the serial connection between RPI and RIO and send the string like !A0 1 1234

Please Log in or Create an account to join the conversation.

More
4 years 8 months ago #29529690 by QuiXXotic

For this big project i would like to use a solid solution. Spent over a half year fulltime developing a quite extensive program using this rioboard to control a robot wich is communicating with and android app. But now its all falling apart due to not being able to control some status led with the analog outputs :P

Please Log in or Create an account to join the conversation.

More
4 years 7 months ago #29529734 by QuiXXotic

Any updates in this matter?

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #29529894 by opal

Hello QuiXXotic,

Thanks for being so patient waiting for the fix.

We have the release candidate that includes a solution for an Analog Output issue.

We are still in progress of testing/verifying this version but in case it is blocking you and you would be willing/interested to test the version early - drop me an email at olegATroboteqDOTcom.

Regards

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #29530333 by mjepson

Well, it's been 3 months since the software was in testing, as I can see. Still no working Analog Outputs? I am trying these since the PWM outputs do not work yet, only to find out the Analog Outputs aren't working yet either?
Help me out here guys, I really have to get this AGV up and running! How do I get the analog output to work from Python? Can I send a serial command from Python? If so, how?!

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #29530334 by QuiXXotic

Sorry to inform you that nothing works really but regular inputs/outputs. I got my hand on a firmware version with somewhat working analog output. One output worked not the other one. Also bought this due to it had it all and that was 15months ago....and i got four of theese...just lying around useless for now due to nothing really works. I constructed my own expansion card with I/Os, pwm, encoder inputs, ADC etc. instead cause i gave up on this. I think it is discountinued btw. If it was sold in my country i would demand money back due to false advertising.....

Please Log in or Create an account to join the conversation.

Moderators: opal
Time to create page: 0.091 seconds
Go to top