Menu

Topic-icon Microbasic Transfer

More
4 years 7 months ago #29529626 by mygoggie

You need to clarify which firmware is the correct one for the RIO board WITH the USB port. On your download site for the RIO there is only one firmware file:

raspioF3-update.zip 24-Sep-2013 06:16 65K

This file is almost a year old and it DOES not state if this is for the board with the USB port.

Please advise as this situation is becoming a real issue of embarrassment for us.

Please Log in or Create an account to join the conversation.

More
4 years 7 months ago #29529627 by mygoggie

roboteq wrote:

The log shows that the firmware file was transfered to the rio. The startup message was not detected after the programming completed and rio rebooted. But this can be a false alarm. If rio is operational after the boot, then it is all ok.

Why was it not detected? Please fix this as well.

There is no way we can update firmware in the field using a serial connection. So please ensure that we receive the correct firmware that is bug free and will work on the RIO with the USB port as a matter of urgency.

Please Log in or Create an account to join the conversation.

  • roboteq
  • roboteq's Avatar
4 years 7 months ago #29529628 by roboteq

Attached are update firmware that fix the scripting problem. The firmware also includes a new CAN protocol that makes it especially easy to talk to Roboteq motor controllers.

Also attached is the menu file for the PC utility. The xml file must be retrieved in Program Files(86)\RoboNav\Trees . Then restart the utility.

The .bin file can be installed using the RS232 port connected to a PC, or via the RPI serial port using minicom. See earlier post on this thread for description of how to update via serial port.

The .dfu file is for updating via USB. When using the PC utility, click on update via USB. will force a reset of rio and it will be in DFU update mode after restarting. The DFULoader will start automatically. You will have to unplug and replug the USB in order for windows to dicover rio while in this mode.

Alternaltively, send %dfu 321644987 from minicom. This will restart rio in dfu mode. Then unplug and replug USB and launc the DFULoader utility.

Note that this update is only for RIO with USB port. Older RIOs witout USB must not be loaded with these files.

Attachments:

Please Log in or Create an account to join the conversation.

More
4 years 7 months ago #29529629 by karman

@roboteq

Thanks for the firmware

I managed to transfer it using the pc utility on rs232. (had no luck with Ymodem on berry or mac via rs232 .. I got the C C C but when sending it just returned immediately.)

Now I have next issue:

The Rio is completely dead. I updated the firmware via the PC utility and all looked good, I thought I will try and do again via the Minicom from my Mac. (on rs232 port), I issued "%RESET 321654987" and it said "Starting...." and nothing else happened.

Power off, power on, nothing. The Status led fast flickers for about 2 seconds then go off. Power led stays on.

I tried now via USB (just said usb device not recognized), via RS232 and via Rasperry minicom but they all give 0 feedback.

Any ideas how to get Rio working again?

Please Log in or Create an account to join the conversation.

  • roboteq
  • roboteq's Avatar
4 years 7 months ago #29529630 by roboteq

Send a phone number to This email address is being protected from spambots. You need JavaScript enabled to view it.

We'll call you and try to go over the process together.

Please Log in or Create an account to join the conversation.

More
4 years 7 months ago - 4 years 7 months ago #29529631 by karman

Thanks for the help,

Firmware updated correctly via usb and serial using a different program. After some digging figured that minicom don't by default have transfer protocols installed.

To get Minicom to work on Arch linux, please install the xmodem, ymodem and zmodem file transfer protocols as its not installed by default and no error is given by minicom that they not installed so nothing happens when you choose transfer file.

To install run: "pacman -S lrzsz"



Now to test the microbasic transfers :)

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #29530022 by beerbot

I am having the same problem as was discussed in this thread: If I select the scripting tab on the PC Utility the RIO halts.

I have a relatively new RIO and it has a USB port.

I am connecting to it with an RS232 cable to an RS232 port on the PC. It communicates fine when I first run the utility.

==> Do I need to use the firmware replacements that you posted in this thread?

==> Is there a way to upload scripts to the RIO without using the PC Utility?

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #29530023 by karman

We gave up on the Rio firmware and rewrote the whole thing, now at least we can use the Rio as planned.

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #29530026 by opal

That's interesting! Could you please share your experience? What exactly have you re-written? What did you achieve? What was the initial objective on the project?

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #29530029 by karman

Opal,

We rewrote the whole firmware and Raspberry code. We wanted to use the the Rio as a automation controller but when we received it realised that most of the functions that we needed was not supported in the firmware although available on the board.

Now that we have our own firmware we can code things as we want.

Please Log in or Create an account to join the conversation.

Moderators: opal
Time to create page: 0.137 seconds
Go to top